BUGS of OPENSTACK: broken dependency of version of openstack-novaclient in tarballs of horizon-9.1.2

WRONG!!!

1
2
3
(.venv) [homitaka@tayn1 horizon]$ egrep novaclient requirements.txt
python-novaclient!=2.33.0,>=2.29.0 # Apache-2.0
(.venv) [homitaka@tayn1 horizon]$

Should be:

1
python-novaclient!=2.33.0,>=2.29.0,<=6.0.0 # Apache-2.0 <<<<<<<<< !!!!!!
1
2
3
(.venv) [homitaka@tayn1 horizon]$ egrep novaclient requirements.txt
python-novaclient!=2.33.0,>=2.29.0 # Apache-2.0
(.venv) [homitaka@tayn1 horizon]$

Leave a Reply

Your email address will not be published. Required fields are marked *

*

Scroll to top